Referenz zum Formatieren von Datumsangaben für CSV-Dateien
Übersicht
Erfahre, wie du Datumsangaben in Excel und Google Sheets bearbeitest, damit sie einem in Klaviyo unterstützten Datumsformat entsprechen. So vermeidest du Datumsformatierungsfehler, wenn du eine CSV mit Kund*innendaten hochlädst.
Wenn du ein E-Commerce-Unternehmen betreibst, das an Kund*innen auf der ganzen Welt verkauft, werden viele dieser Kund*innen Datumsangaben unterschiedlich formatieren. Wenn du ebenso Datumsangaben aus einer Excel- oder Google-Sheets-Datei importierst, können diese Systeme Datumsangaben gemäß ihren Standard-Datumeinstellungen neu formatieren. Excel kann beispielsweise „1. März 2020“ in „1. März“ neu formatieren.
Wenn du Daten für eine benutzerdefinierte Profileigenschaft importierst, ordne Werte, die eine Zeit enthalten, dem Datentyp Date zu. Wenn du ein Datum ohne Zeit dem Typ Date zuordnest, wendet Klaviyo Mitternacht UTC an. Dadurch kann sich das Kalenderdatum verschieben, das von einem datumsausgelösten Flow verwendet wird, wenn der Wert in die Zeitzone der Empfänger*in konvertiert wird, oder in die Zeitzone des Kontos, wenn die Zeitzone der Empfänger*in nicht verfügbar ist. Bei Daten ohne Zeit, wie Geburtstagen, wähle Text aus, um das beabsichtigte Kalenderdatum beizubehalten.
Zulässige Datums- und Zeitstempelformate
Verwende für Werte, die nur ein Datum enthalten, YYYY-MM-DD oder MM/DD/YYYY. Diese Formate verwenden ein 4-stelliges Jahr, um Mehrdeutigkeiten zu vermeiden. Klaviyo liest durch Schrägstriche getrennte Datumsangaben als Monat/Tag/Jahr, unabhängig vom Gebietsschema deiner Tabelle. Bei Datumsangaben ohne Uhrzeit befolge die Zuordnungsrichtlinien für Text oben.
Verwende für Zeitstempel das 24-Stunden-Format. Wenn ein Zeitstempel ohne Zeitzonen-Offset Date zugeordnet ist, wird er als UTC interpretiert. Um eine andere Zeitzone anzugeben, füge ihren UTC-Offset hinzu, z. B. 2014-09-30 13:34:08-04:00. Der Offset +00:00 bedeutet UTC.
Wenn du bei deinen Zeitstempeln keine Sekunden angibst, werden sie standardmäßig auf 0 gesetzt. Ein Zeitstempel von 2014-09-30 13:34 würde beispielsweise so an Klaviyo übermittelt werden: 2014-09-30 13:34:00
Die folgenden Beispiele zeigen unterstützte Zeitstempelformate. Sie veranschaulichen unterschiedliche Genauigkeitsstufen und Zeitzonenauswahlen, sodass sie nicht alle denselben Zeitpunkt darstellen:
2014-09-30 13:34:082014-09-30 13:34:08+00:0009/30/2014 13:34:0809/30/14 13:34:0809/30/2014 13:3409/30/14 13:342014-09-30T13:34:082014-09-30 13:34:08.0000012014-09-30T13:34:08.0000012014-09-30 13:34:08.000001-04:001412098448(Unix)
Microsoft Excel
Zur Konsistenz bearbeiten
Um Datums- und Zeitstempel in einer Excel-Datei zu bearbeiten, wähle zuerst die Zellen aus, die du neu formatieren möchtest. Drücke Command+1 oder Control+1 (wenn du macOS verwendest) oder CTRL+1 (wenn du Windows verwendest). Anleitungen für deine Excel-Version findest du in Microsofts Leitfaden zur Datumsformatierung.

Ein Pop-up Zellen formatieren wird angezeigt. Wähle im Haupt-Tab Nummer aus (falls er nicht bereits ausgewählt ist) und wähle unter Kategorie Datum aus.

Wähle unter Typ das gewünschte Datumsformat aus. Stelle sicher, dass du ein Datums- und Zeitstempelformat auswählst, das in Klaviyo unterstützt wird.
Wenn du zum Beispiel 2012-03-14 auswählst (was in Klaviyo unterstützt wird), bestätige das Format mit OK, um es auf die ausgewählten Zellen anzuwenden.

Für Standort bearbeiten
Die regionalen Einstellungen von Excel können sich auf die Standard-Datumsformate auswirken. Anleitungen für deine Version findest du in Microsofts Anleitung zu Datumsformaten und regionalen Einstellungen.
Ein Datum im UK-Format verwendet die Reihenfolge Tag/Monat, während Klaviyo durch Schrägstriche getrennte Datumsangaben als Monat/Tag liest. Klaviyo liest 05/08/2020 beispielsweise als den 8. Mai 2020 und nicht als den 5. August. Bevor du deine CSV speicherst, formatiere Datumsangaben als YYYY-MM-DD oder MM/DD/YYYY, auch wenn du ein UK-Gebietsschema verwendest.

Sobald deine Excel-Datei das korrekte Datums-/Zeitstempelformat aufweist, auf Datei > Speichern unter klicken. Datei als CSV speichern.
Gehe dann zurück zu deinem Klaviyo-Konto und lade deine CSV-Datei in eine Liste hoch.
Wenn diese Kund*innen bereits in deinem Konto vorhanden sind, werden beim Hochladen deiner CSV in deine Liste keine neuen Profile hinzugefügt. Stattdessen wird ihr Profil aktualisiert, um die Änderungen zu übernehmen, die du beim Zuordnen von Feldern vornimmst. So vermeidest du doppelte Kund*innendaten und ein unübersichtliches Konto.
Google Tabellen
Für Standort bearbeiten
In Google Sheets kannst du Datumsangaben auch so ändern, dass sie deinem nativen Datumsformat bzw. deiner Locale entsprechen. Wenn du beispielsweise im Vereinigten Königreich bist, möchtest du das US-Datumsformat (MM/DD) vielleicht in das UK-Format (DD/MM) ändern.
Um die Spracheinstellung oder Zeitzone deiner Tabelle zu ändern, folge Googles Anleitung für Tabelleneinstellungen.

Das Ändern des Gebietsschemas wirkt sich auf die Standardformate für Datum, Zahlen und Währung in der Tabelle für alle aus, die die Tabelle verwenden. Die Anzeigesprache von Google Tabellen wird dadurch nicht geändert.
Ein Gebietsschema für das Vereinigte Königreich kann beispielsweise Daten im Format Tag/Monat/Jahr anzeigen. Bevor du die CSV-Datei für Klaviyo exportierst, wende YYYY-MM-DD oder MM/DD/YYYY wie unten beschrieben an.
Lege dein Gebietsschema fest, bevor du das endgültige Datumsformat auswählst. Wenn du das Gebietsschema später änderst, überprüfe die Datumsangaben vor dem Exportieren noch einmal. Sie sollten weiterhin YYYY-MM-DD oder MM/DD/YYYY verwenden.
Zur Konsistenz bearbeiten
Um Datums- und Zeitstempel in einer Google-Tabelle zur Konsistenz zu bearbeiten, wähle die Zellen aus, die du neu formatieren möchtest.

Wähle Format > Zahl > Datum (oder Datum/Uhrzeit, wenn du sowohl das Datum als auch die Uhrzeit in deiner Datei bearbeiten möchtest).

Dadurch werden deine Datumsangaben aktualisiert, damit sie die Standardformatierung von Google Sheets widerspiegeln, wie im Bild unten gezeigt.

Alternativ kannst du Datumsinformationen finden, indem du die Drop-down-Liste 123 auswählst.

Da du jetzt ein einheitliches Format in deiner Tabelle hast, stell sicher, dass es mit Klaviyos Richtlinien zum Formatieren von Daten und Zeitstempeln übereinstimmt.
Führende Nullen in durch Schrägstriche getrennten Monaten und Tagen sind optional: 8/5/1930 und 08/05/1930 bedeuten beide den 5. August 1930 in Klaviyo. Du kannst für mehr Konsistenz trotzdem führende Nullen verwenden. Um das Format zu ändern, folge Googles Anweisungen zur benutzerdefinierten Datums- und Uhrzeitformatierung.

Wähle YYYY-MM-DD oder MM/DD/YYYY für Werte, die nur aus einem Datum bestehen. Wenn deine Spalte eine Zeitangabe enthält, wähle eines der oben unterstützten Zeitstempelformate aus. Klicke auf Anwenden.
Zum Beispiel ist 08/05/1930 ein akzeptables Datumsformat in Klaviyo, wenn es den 5. August 1930 bedeutet. Um den 8. Mai 1930 darzustellen, verwende 1930-05-08 oder 05/08/1930.

Dadurch werden alle deine Daten aktualisiert, sodass sie in deinem gewünschten Format angezeigt werden. Anschließend können sie in Klaviyo hochgeladen werden.

Navigiere dort zu Datei > Herunterladen und lade dein Google Sheet als CSV-Datei herunter. Als Nächstes kannst du deine CSV-Datei in eine Klaviyo-Liste hochladen.
Wenn diese Kund*innen bereits in deinem Konto vorhanden sind, werden beim Hochladen deiner CSV in deine Liste keine neuen Profile hinzugefügt. Stattdessen wird ihr Profil aktualisiert, um die Änderungen zu übernehmen, die du beim Zuordnen von Feldern vornimmst. So vermeidest du doppelte Kund*innendaten und ein unübersichtliches Konto.
Aus Datenschutzgründen kann das Support-Team von Klaviyo deine CSV-Dateien nicht öffnen. Wenn du Unterstützung bei der Fehlerbehebung bei einem Listenimport benötigst, wende dich mit einer detaillierten Beschreibung des Problems und Screenshots des Fehlers, der bei dir auftritt, an das Support-Team.
CSV-Upload-Beispiel
Unten findest du ein Beispiel dafür, wie diese CSV-Datei aussehen kann, wenn du sie mit den korrekten Datums-/Zeitformaten hochlädst.

Weitere Ressourcen
- Zulässige Datums- und Zeitstempelformate für Profil- und Ereigniseigenschaften – Referenz
Erfahre, welche Datums- und Zeitformate Klaviyo in Ereignis- und Profildaten erkennt, die über unsere APIs oder per CSV-Upload gesendet werden. Beachte, dass dies nicht für einen Ereigniszeitstempel gilt, der über die Track API gesendet wird; dieser muss Unix-Zeit in Sekunden sein.
- Leitfaden zu Profileigenschaften
In diesem Artikel erfährst du, was der Unterschied zwischen benutzerdefinierten Eigenschaften und Klaviyo-Eigenschaften ist, wie du sie zum Verfolgen von Informationen über deine Abonnent*innen verwendest und wie du sie wieder entfernst. Dazu gibt es Best Practices und vieles mehr.